Skip to content
GitLab
Explore
Sign in
Primary navigation
Search or go to…
Project
debian
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Build
Pipelines
Jobs
Pipeline schedules
Artifacts
Deploy
Releases
Container Registry
Model registry
Operate
Environments
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
Docker Build Images
debian
Commits
e83be419
Commit
e83be419
authored
6 years ago
by
Markus Frosch
Browse files
Options
Downloads
Patches
Plain Diff
Add latest tag for x86_64
parent
6d5b4612
No related branches found
No related tags found
No related merge requests found
Pipeline
#2505
passed
6 years ago
Stage: build
Changes
2
Pipelines
1
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
.gitlab-ci.yml
+2
-2
2 additions, 2 deletions
.gitlab-ci.yml
image.mk
+12
-0
12 additions, 0 deletions
image.mk
with
14 additions
and
2 deletions
.gitlab-ci.yml
+
2
−
2
View file @
e83be419
...
...
@@ -6,12 +6,12 @@ stages:
-
build
variables
:
DOCKER_REGISTRY
:
registry.icinga.com
DOCKER_REGISTRY
:
${CI_REGISTRY}
DOCKER_IMAGE_PREFIX
:
${CI_PROJECT_PATH}/
before_script
:
-
docker info
-
docker login -u gitlab-ci-token -p $CI_JOB_TOKEN
registry.icinga.com
-
docker login -u gitlab-ci-token -p $CI_JOB_TOKEN
${CI_REGISTRY}
-
apk -U add make
.build_job
:
&build_job
...
...
This diff is collapsed.
Click to expand it.
image.mk
+
12
−
0
View file @
e83be419
...
...
@@ -15,6 +15,12 @@ DIST := $(shell basename $$(dirname `pwd`))
VARIANT
:=
$(
shell
basename
`
pwd
`
)
IMAGE
:=
$(
IMAGE_PREFIX
)$(
DIST
)
:
$(
VARIANT
)
ifeq
($(VARIANT),x86_64)
IMAGE_EXTRA
:=
$(
IMAGE_PREFIX
)$(
DIST
)
:latest
else
IMAGE_EXTRA
:=
endif
all
:
pull build
pull
:
...
...
@@ -23,9 +29,15 @@ pull:
build
:
docker build
--cache-from
"
${
IMAGE
}
"
--tag
"
$(
IMAGE
)
"
.
ifneq
($(IMAGE_EXTRA),)
docker tag
"
$(
IMAGE
)
"
"
$(
IMAGE_EXTRA
)
"
endif
push
:
docker push
"
$(
IMAGE
)
"
ifneq
($(IMAGE_EXTRA),)
docker push
"
$(
IMAGE_EXTRA
)
"
endif
clean
:
if
(
docker inspect
--type
image
"
$(
IMAGE
)
"
>
/dev/null 2>&1
)
;
then
docker rmi
"
$(
IMAGE
)
"
;
fi
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment