Commit fce159f1 authored by Johannes Meyer's avatar Johannes Meyer
Browse files

Require 7.2 => php <= 8.1

parent 3da61bb0
Pipeline #25152 passed with stages
in 3 minutes and 17 seconds
......@@ -18,9 +18,6 @@ Packager: Icinga GmbH <info@icinga.com>
%if 0%{?rhel} == 7
%define php_scl rh-php73
%endif
%if 0%{?rhel} == 6
%define php_scl rh-php70
%endif
%if 0%{?el5}%{?el6}%{?amzn}
%define use_selinux 0
......@@ -50,7 +47,10 @@ Requires: %{php}-ldap
%endif
# minimum required PHP version
%define php_version 5.6.0
%define php_version 7.2
# maximum supported PHP version
%define php_max_version 8.1
%if 0%{?suse_version}
%define wwwconfigdir %{_sysconfdir}/apache2/conf.d
......@@ -59,10 +59,6 @@ Requires: %{php}-ldap
%define php_runtime mod_php_any
%define php_common %{php}
%define php_cli %{php}
# conflict with older PHP on SLES and openSUSE
Conflicts: php < %{php_version}
Conflicts: php5 < %{php_version}
Conflicts: php53
%endif
%{?amzn:Requires(pre): shadow-utils}
......@@ -72,6 +68,7 @@ Conflicts: php53
Requires: %{php_runtime} >= %{php_version}
Requires: %{php_common} >= %{php_version}
Conflicts: %{php_runtime} > %{php_max_version}
%if 0%{?suse_version}
Requires: apache2
%endif
......@@ -148,12 +145,6 @@ Requires: icinga-php-library >= 0.8.0-1
Requires: icinga-php-thirdparty >= 0.10.0-1
Requires: bash-completion
Requires: %{php_cli} >= %{php_version}
%if 0%{?suse_version}
# conflict with older PHP on SLES and openSUSE
Conflicts: php < %{php_version}
Conflicts: php5 < %{php_version}
Conflicts: php53
%endif
%description -n icingacli
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment