Commit a258b477 authored by Markus Frosch's avatar Markus Frosch 📣

Rakefile: Add and enable parallel_spec by default

parent 3fb5b295
......@@ -10,3 +10,5 @@ gem 'rspec-puppet-facts', '>= 1.6.0'
gem 'json', jsonversion
gem 'json_pure', jsonversion
gem 'metadata-json-lint'
gem 'parallel_tests', RUBY_VERSION < '2.0.0' ? '~> 2.9.0' : '>= 2.10.0'
......@@ -20,5 +20,5 @@ exclude_paths = %w(
PuppetLint.configuration.ignore_paths = exclude_paths
PuppetSyntax.exclude_paths = exclude_paths
desc 'Run validate, spec, lint'
task test: %w(metadata_lint validate spec lint)
desc 'Run validate, parallel_spec, lint'
task test: %w(metadata_lint validate parallel_spec lint)
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment